Welcome, Guest
Username: Password: Remember me
Hier wird Deutsch gesprochen
  • Page:
  • 1

TOPIC:

warning XS1701 Fehler XS1061 08 May 2022 10:34 #22377

  • lagraf


  • Posts: 265
  • Wenn ich eine meiner X# Apps mit ReportPro seit Installation der X# Compiler Version 2.10 compiliere, bekomme ich jede Menge Warnings XS1701, dass die Library Versionen zwischen meiner App (2.6.0.0) und ReportPro (2.1.0.0) nicht zusammenpassen, obwohl ich ReportPro 2.35 installiert habe, was für X# 2.10 passen sollte.

    Lade ich mir die aktuelle Version von ReportPro 2.35 für X# 2.10 herunter und entpacke sie, erhalte ich viele Fehler XS7036, dass die Argumente bei SetPrinterByName, SetVariableValue, SQLFilterWhere, etc nicht passen.

    Anscheinend gibt es da ältere und neuere ReportPro Versionen 2.35. Wie komme ich aber nun zu einer passenden, die ohne Fehler und Warnings meine App compiliert?

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 08 May 2022 13:27 #22378

    • Chris
    • Chris's Avatar


  • Posts: 3256
  • Hi Franz,

    The version numbers are probably a bit misleading, but we are currently at X# version (2.)110, while the RP2 version you are trying to use was designed to work with builds (2.)010 to (2.)050. For the later X# versions, you indeed need RP2 >= 2.36.

    Can you please post a sample with the exact error messages you are getting and the code producing them? I'm sure it will be easy to adjust the code to remove those errors.

    .
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 11:20 #22379

    • lagraf


  • Posts: 265
  • Hi Chris,
    since I upgraded xsc to 2.10.0.3 I can't compile all my X# apps which contain RP2. I attach a small testapp "RPChris" you already should know. I use 2 different RP2 2.35 versions with different behaviour. References to RP2 point to C:\RP235.

    RP235old.zip brings warnings and crashes at start:
    warning XS1701: Assuming assembly reference 'XSharp.RT, Version=2.1.0.0, Culture=neutral, PublicKeyToken=ed555a0467764586' used by 'ReportPro2.Runtime' matches identity 'XSharp.RT, Version=2.6.0.0, Culture=neutral, PublicKeyToken=ed555a0467764586' of 'XSharp.RT', you may need to supply runtime policy

    RP235new brings errors at all RP2 calls:
    error XS7036: There is no argument given that corresponds to the required formal parameter 'cPort' of 'ReportPro2.PtrDevice.SetPrinterByName(string, string)'

    What could be the problem? All my apps without RP2 compile well.
    Attachments:

    Please Log in or Create an account to join the conversation.

    Last edit: by Chris.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 13:13 #22382

    • Chris
    • Chris's Avatar


  • Posts: 3256
  • Hi Franz,

    Sorry, I had to remove your attachments from your message, since you posted dlls of a 3rd party product (RP2) which is not free.

    I did try your code though and did not get any errors. Can you please show the exact lines of code in which you are getting the error XS7036?

    Edit: Ah, just noticed, you are still using RP2.35. As I mentioned in my previous message, please use RP version 2.36 or higher.

    .
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    Last edit: by Chris.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 16:53 #22391

    • lagraf


  • Posts: 265
  • My older RP2 2.35 version brings when compiling RP2Chris
    warning XS1701: Assuming assembly reference 'XSharp.RT, Version=2.1.0.0, Culture=neutral, PublicKeyToken=ed555a0467764586' used by 'ReportPro2.Runtime' matches identity 'XSharp.RT, Version=2.6.0.0, Culture=neutral, PublicKeyToken=ed555a0467764586' of 'XSharp.RT', you may need to supply runtime policy	24,3	Class rptSummen.prg	rptSummen:.ctor
    When starting original big app it crashes with


    The actual version RP2 2.35 from xsharp.eu Downloads brings
    error XS7036: There is no argument given that corresponds to the required formal parameter 'cPort' of 'ReportPro2.PtrDevice.SetPrinterByName(string, string)'	22,3	Class rptSummen.prg	rptSummen:.ctor
    Attachments:

    Please Log in or Create an account to join the conversation.

    Last edit: by lagraf.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 17:00 #22392

    • Chris
    • Chris's Avatar


  • Posts: 3256
  • Hi Franz,

    As I said, you must use RP 2.36 or higher, NOT 2.35.

    Again you did not show the line of your code that produces the error. But I checked your code and I assume it's this one:

    oPrinter:SetPrinterByName(cPrinter)

    you can provide the 2nd parameter manually:

    oPrinter:SetPrinterByName(cPrinter,"")

    and this error will go away, but I'm sure you will have more issues later. So please use RP 2.36 or higher. Maybe it's because of language difference and it is not clear what I am saying, so Wolfgang can you please step in and explain to Franz in German, that he needs to use RP2 version 2.36 or higher? TIA!

    .
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 17:13 #22394

    • lagraf


  • Posts: 265
  • oh, sorry I skipped your remark concerning 2.36, I used 2.35 because on the download page its recommended for x# 2.10!

    I'll give 2.36 a try!

    I gave you the full messages with line and pos, cause I thought that's better for you to see the statements in original source not in a screenshot.
    Attachments:

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 17:32 #22395

    • Chris
    • Chris's Avatar


  • Posts: 3256
  • Hi Franz,

    Yeah, I also explained that about version numbers in my first reply :) www.xsharp.eu/forum/german/2991-warning-...-xs1061-xs7036#22378

    I think we will need to use more appropriate version numbers for the X# 3.0 series.

    .
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 18:03 #22396

    • wriedmann
    • wriedmann's Avatar


  • Posts: 3047
  • Hi Chris,
    if I can suggest something: write minor version numbers with a leading 0:
    3.00
    3.01
    3.02
    ......
    3.11
    3.12
    and so forth, so they may even in alfabetical order.
    If a sub-version is needed, you can always add a letter:
    3.11
    3.11a
    3.11b
    3.12
    And for the 3rd party libraries I would recommend to put them in subfolders for every needed runtime, and change the name accordingly when a new version comes out:
    ReportPro 2 for VO 2.8
    ReportPro 2 for X# 2.06 to 2.11
    ReportPro 2 for X# 3.00 to 3.12a
    Hopefully that could help a bit.
    Wolfgang
    Wolfgang Riedmann
    Meran, South Tyrol, Italy

    www.riedmann.it - docs.xsharp.it

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 09 May 2022 18:04 #22397

    • Chris
    • Chris's Avatar


  • Posts: 3256
  • Hi Wolfgang,

    Yeah, that's exactly what I was thinking as well.
    XSharp Development Team
    chris(at)xsharp.eu

    Please Log in or Create an account to join the conversation.

    warning XS1701 Fehler XS1061 XS7036 13 May 2022 05:52 #22442

    • lagraf


  • Posts: 265
  • Chris,
    thank you very much, RP2 2.36 does well!

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1
    Moderators: wriedmann