Welcome, Guest
Username: Password: Remember me
Visual Objects

Please use this forum to post questions about Visual Objects and Vulcan.NET
  • Page:
  • 1

TOPIC:

Can't compile OleWebBrowser 19 Nov 2021 16:50 #20469

  • FdeRaadt


  • Posts: 9
  • Good afternoon guys,

    I'm trying to export some Libraries from an old project to a newer one.
    I've done this by making AEF's of the Libraries i wish to export.
    When i loaded up the new project i used the File > Import function to import all the Libraries from the AEF's.

    When i run the compiler at the new project/library/module it results in 65 out of 66 dead entities.
    This is very weird because i've done the same proces in a barebones project which didnt give me any errors.

    The Module in question only uses base libraries such as OLE, GUI CLASSES and SYSTEM CLASSES.
    These base libraries have been included by properties but still result in 65/66 dead entities.

    I shall include some screenshots for addional context.

    Has this happened to anyone before?
    I'm probadly missing something very simple but i can't figure it out at the moment.

    With Kind Regards

    Frank

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 20 Nov 2021 06:42 #20472

    • wriedmann
    • wriedmann's Avatar


  • Posts: 2836
  • Hi Frank,
    please try to reindex your repo, following by a complete rebuild of the entre project.
    Wolfgang
    Wolfgang Riedmann
    Meran, South Tyrol, Italy

    www.riedmann.it - docs.xsharp.it

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 20 Nov 2021 10:50 #20473

    • Karl-Heinz


  • Posts: 712
  • Hi Frank,

    i suggest to do a *external* reindex.

    - close VO
    - Doubleclick in the cavo bin folder the file "reindex.exe".
    - now reindex the "Kleijn202103" project.

    If there are still problems to build the "__OleWebBrowser" app. Select the app, do a right click and select "Touch"

    regards
    Karl-Heinz

    Please Log in or Create an account to join the conversation.

    Last edit: by Karl-Heinz.

    Can't compile OleWebBrowser 21 Nov 2021 08:08 #20476

    • ic2


  • Posts: 1183
  • Hello Wolfgang, Karl-Heinz,

    We tried reindexing and touching. We've deleted the mef's and reimported it, same result (while the same AEF imports & compiles without problems in any other repo). And every other AEF (which does not include this OleWebBrowser) compiles fine in the same repo.

    I've never seen this before but what we didn't try is an external reindex. We'll do that Monday.

    Dick

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 22 Nov 2021 11:16 #20479

    • FdeRaadt


  • Posts: 9
  • Hello everyone,

    I've tried the external reindex.
    After that i also did "Touch" the project.

    Unfortunately the result is still the same.

    Frank

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 22 Nov 2021 13:44 #20482

    • robert
    • robert's Avatar


  • Posts: 2475
  • Frank,
    Can you ZIP the repo folder and mail it to me ?
    Your image shows that you're using VO 2.8 SP4. Do your other projects also use 2.8 SP4 ?

    Robert
    XSharp Development Team
    The Netherlands

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 22 Nov 2021 15:13 #20484

    • FdeRaadt


  • Posts: 9
  • Hello Everyone,

    What i've tried which seems to work are following steps.
    1. Export all AEF's from the Repo with the problem.
    2. Create a new project
    3. Import all AEF's with the File/Import (recommended to skip readme's to save yourself some unnecessary clicks)
    4. Go to Tools/More VO Productivity pack, system builder, Ok
    for some reason my 65 out of 66 dead entities are gone.
    I have no clue what caused the issue or why this fix works.
    All i know is that the problem magicly disappeared and I can continue with my life

    Frank

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 22 Nov 2021 15:36 #20485

    • ic2


  • Posts: 1183
  • Hello Robert,

    What we often do is copy a whole project directory. Frank copied the last directory from the "life" project for reference as he his working on the X# conversion and documents the changes which must be made in the life VO project first before a 'real' conversion will be done.

    We've exchanged this other repo's for years without issues but I suspect that there has been some issue in this specific repo (which is not copied often); an issue which didn't manifest until copied now, although you would expect it to work the same.

    I think you should not spend your time in finding out "why" as the rebuild strategy worked. I was just wondering if there would be some other cause or setting for the OleWebBrowser failing to compile, apparently it should have worked...

    Dick

    Please Log in or Create an account to join the conversation.

    Can't compile OleWebBrowser 22 Nov 2021 21:30 #20488

    • Jamal


  • Posts: 261
  • Frank,

    Was the library created using an older of version of VO?

    May be the OLE classes are incompatible since VO 2.8.x generates and uses new classes with different names and the compiler thus cannot find them.

    Could you provide one of the existing generated methods to verify if that's the case?

    Jamal

    Please Log in or Create an account to join the conversation.

    Last edit: by Jamal.

    Can't compile OleWebBrowser 23 Nov 2021 11:20 #20492

    • ic2


  • Posts: 1183
  • Hello Jamal,

    No, it was a copied & working (on the source Pc) repo from the same (latest) VO version.

    Dick

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1