Welcome, Guest
Username: Password: Remember me
Visual Objects

Please use this forum to post questions about Visual Objects and Vulcan.NET
  • Page:
  • 1

TOPIC:

VO2838: Debug error while showing variables 04 Oct 2022 17:20 #24098

  • kitz
  • kitz's Avatar
  • Topic Author


  • Posts: 82
  • Hello,
    I have problems while debugging in VO2838 (Win10 Enterprise 64 Bit, 21H2):
    First few attempts it says *** err type: 0x00000033 *** instead of variable contents (see attached picture)
    after a while of debugging just an empty content or NIL.
    In the picture dwLen is just a local dword.
    Same while hovering over variables in source code.

    Any ideas?
    BR Kurt

    Please Log in or Create an account to join the conversation.

    VO2838: Debug error while showing variables 05 Oct 2022 10:28 #24099

    • ic2
    • ic2's Avatar


  • Posts: 1555
  • Hello Kurt,

    It often helps to reindex the VO repository.

    Dick

    Please Log in or Create an account to join the conversation.

    VO2838: Debug error while showing variables 05 Oct 2022 11:00 #24102

    • kitz
    • kitz's Avatar
    • Topic Author


  • Posts: 82
  • Dick,
    I tried, but no change.
    Thx
    BR Kurt

    Please Log in or Create an account to join the conversation.

    VO2838: Debug error while showing variables 05 Oct 2022 21:33 #24105

    • ic2
    • ic2's Avatar


  • Posts: 1555
  • I found some more info about this specific error. Someone got it when trying:
    Get_date(Today())

    After changing
    function Get_date(dDate)
    return dDate

    to
    function Get_date(dDate as Date)
    the problem was gone. But I would expect retrieving your variable (not a function call) in Ctrl X should not give that error (maybe only when you defined it as usual, but I think it must be a Dword.

    Cause nr 2 (I had that myself years ago) was solved after SP2, but 2828 is SP4..

    Solution nr 3 is reindexing but sometimes you need to create a new repo and import all AEF's. VOPP helps you rebuild easily.

    Do you have the same error with running functions or showing other variables?

    Dick

    Please Log in or Create an account to join the conversation.

    Last edit: by ic2.

    VO2838: Debug error while showing variables 06 Oct 2022 08:29 #24108

    • kitz
    • kitz's Avatar
    • Topic Author


  • Posts: 82
  • Hi!
    I have issues with EVERY variable, never any content is shown. There are different *** err with hex codes.
    After some time it just tells the variable name but no more content.
    Same effect with ctrl-x.
    But if I open the local window in debug I see the variable content.
    With show call stack it works, too.
    Weird...
    BR Kurt

    Please Log in or Create an account to join the conversation.

    • Page:
    • 1